import Foundation
let pattern = #"^(?<first>[a-fA-F\d]{8})-?(?<second>[a-fA-F\d]{4})-?(?<third>[a-fA-F\d]{4})-?(?<fourth>[a-fA-F\d]{4})-?(?<fifth>[a-fA-F\d]{12})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
aa76ae52-14f2-5774-A645-9d002a72dec1
aa76ae5214f25774A6459d002a72dec1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)