package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<first>[a-fA-F\d]{8})-?(?<second>[a-fA-F\d]{4})-?(?<third>[a-fA-F\d]{4})-?(?<fourth>[a-fA-F\d]{4})-?(?<fifth>[a-fA-F\d]{12})$`)
var str = `aa76ae52-14f2-5774-A645-9d002a72dec1
aa76ae5214f25774A6459d002a72dec1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}