import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<first>[a-fA-F\\d]{8})-?(?<second>[a-fA-F\\d]{4})-?(?<third>[a-fA-F\\d]{4})-?(?<fourth>[a-fA-F\\d]{4})-?(?<fifth>[a-fA-F\\d]{12})$";
final String string = "aa76ae52-14f2-5774-A645-9d002a72dec1\n"
+ "aa76ae5214f25774A6459d002a72dec1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}