const regex = /^(?<first>[a-fA-F\d]{8})-?(?<second>[a-fA-F\d]{4})-?(?<third>[a-fA-F\d]{4})-?(?<fourth>[a-fA-F\d]{4})-?(?<fifth>[a-fA-F\d]{12})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<first>[a-fA-F\\d]{8})-?(?<second>[a-fA-F\\d]{4})-?(?<third>[a-fA-F\\d]{4})-?(?<fourth>[a-fA-F\\d]{4})-?(?<fifth>[a-fA-F\\d]{12})$', 'gm')
const str = `aa76ae52-14f2-5774-A645-9d002a72dec1
aa76ae5214f25774A6459d002a72dec1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}