re = /[0-7][0-9A-HJKMNP-TV-Z]{25}/m
str = '01G9HHNKWGBHCQX7VG3JKSZ055
01G9HHNTQY2E8HM5N9AE5SQBXQ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end