use strict;
my $str = '01G9HHNKWGBHCQX7VG3JKSZ055
01G9HHNTQY2E8HM5N9AE5SQBXQ';
my $regex = qr/[0-7][0-9A-HJKMNP-TV-Z]{25}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}