const regex = /[0-7][0-9A-HJKMNP-TV-Z]{25}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-7][0-9A-HJKMNP-TV-Z]{25}', 'gm')
const str = `01G9HHNKWGBHCQX7VG3JKSZ055
01G9HHNTQY2E8HM5N9AE5SQBXQ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}