$re = '/[0-7][0-9A-HJKMNP-TV-Z]{25}/m';
$str = '01G9HHNKWGBHCQX7VG3JKSZ055
01G9HHNTQY2E8HM5N9AE5SQBXQ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);