const regex = /Ctrl-S(\s(=\s)?(\w+\/?\w?)+)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Ctrl-S(\\s(=\\s)?(\\w+\\\/?\\w?)+)+', 'gm')
const str = `Ctrl-T Chg Task Grp Ctrl-R Refresh Ctrl-P Chg Printer Ctrl-E Enter Task `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}