import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Ctrl-S(\\s(=\\s)?(\\w+\\/?\\w?)+)+";
final String string = "Ctrl-T Chg Task Grp Ctrl-R Refresh Ctrl-P Chg Printer Ctrl-E Enter Task ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}