const regex = /^(((h..ps?|f.p):\/\/)?(?:([\w\-\.])+(\[?\.\]?)([\w]){2,4}|(?:(?:25[0-5]|2[0-4]\d|[01]?\d\d?)\[?\.\]?){3}(?:25[0-5]|2[0-4]\d|[01]?\d\d?)))*([\w\/+=%&_\.~?\-]*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((h..ps?|f.p):\\\/\\\/)?(?:([\\w\\-\\.])+(\\[?\\.\\]?)([\\w]){2,4}|(?:(?:25[0-5]|2[0-4]\\d|[01]?\\d\\d?)\\[?\\.\\]?){3}(?:25[0-5]|2[0-4]\\d|[01]?\\d\\d?)))*([\\w\\\/+=%&_\\.~?\\-]*)$', 'gm')
const str = `www[.]domain[.]com
www.domain.com
hxxp://www[.]domain[.]com
192.168.8.1/folder/file.html
192.168.1[.]1
192.168.1[.]1/folder/file.html
192[.]168[.]1[.]1/folder/file.html
hxxp://www[.]domain[.]com/folder/file.html
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}