import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((h..ps?|f.p):\\/\\/)?(?:([\\w\\-\\.])+(\\[?\\.\\]?)([\\w]){2,4}|(?:(?:25[0-5]|2[0-4]\\d|[01]?\\d\\d?)\\[?\\.\\]?){3}(?:25[0-5]|2[0-4]\\d|[01]?\\d\\d?)))*([\\w\\/+=%&_\\.~?\\-]*)$";
final String string = "www[.]domain[.]com\n"
+ "www.domain.com\n"
+ "hxxp://www[.]domain[.]com\n\n"
+ "192.168.8.1/folder/file.html\n\n"
+ "192.168.1[.]1\n"
+ "192.168.1[.]1/folder/file.html\n"
+ "192[.]168[.]1[.]1/folder/file.html\n"
+ "hxxp://www[.]domain[.]com/folder/file.html\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}