using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((h..ps?|f.p):\/\/)?(?:([\w\-\.])+(\[?\.\]?)([\w]){2,4}|(?:(?:25[0-5]|2[0-4]\d|[01]?\d\d?)\[?\.\]?){3}(?:25[0-5]|2[0-4]\d|[01]?\d\d?)))*([\w\/+=%&_\.~?\-]*)$";
string input = @"www[.]domain[.]com
www.domain.com
hxxp://www[.]domain[.]com
192.168.8.1/folder/file.html
192.168.1[.]1
192.168.1[.]1/folder/file.html
192[.]168[.]1[.]1/folder/file.html
hxxp://www[.]domain[.]com/folder/file.html
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}