#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((h..ps?|f.p):\/\/)?(?:([\w\-\.])+(\[?\.\]?)([\w]){2,4}|(?:(?:25[0-5]|2[0-4]\d|[01]?\d\d?)\[?\.\]?){3}(?:25[0-5]|2[0-4]\d|[01]?\d\d?)))*([\w\/+=%&_\.~?\-]*)$"
Local $sString = "www[.]domain[.]com" & @CRLF & _
"www.domain.com" & @CRLF & _
"hxxp://www[.]domain[.]com" & @CRLF & _
"" & @CRLF & _
"192.168.8.1/folder/file.html" & @CRLF & _
"" & @CRLF & _
"192.168.1[.]1" & @CRLF & _
"192.168.1[.]1/folder/file.html" & @CRLF & _
"192[.]168[.]1[.]1/folder/file.html" & @CRLF & _
"hxxp://www[.]domain[.]com/folder/file.html" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")