// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-2][0-9]|(3)[0-1])(\/)(((0)[0-9])|((1)[0-2]))$").unwrap();
let string = "31/12
30/12
01/01
a01/02
01/01basdasd
32/01
32/12
01/13
32/13
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}