#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-2][0-9]|(3)[0-1])(\/)(((0)[0-9])|((1)[0-2]))$"
Local $sString = "31/12" & @CRLF & _
"30/12" & @CRLF & _
"01/01" & @CRLF & _
"a01/02" & @CRLF & _
"01/01basdasd" & @CRLF & _
"32/01" & @CRLF & _
"32/12" & @CRLF & _
"01/13" & @CRLF & _
"32/13" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")