$re = '/^([0-2][0-9]|(3)[0-1])(\/)(((0)[0-9])|((1)[0-2]))$/m';
$str = '31/12
30/12
01/01
a01/02
01/01basdasd
32/01
32/12
01/13
32/13
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);