const regex = /^([0-2][0-9]|(3)[0-1])(\/)(((0)[0-9])|((1)[0-2]))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-2][0-9]|(3)[0-1])(\\\/)(((0)[0-9])|((1)[0-2]))$', 'gm')
const str = `31/12
30/12
01/01
a01/02
01/01basdasd
32/01
32/12
01/13
32/13
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}