// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^#\s(?P<header>(\w+='\w+')(,\s*(\w+='\w+'))*)$").unwrap();
let string = "# type='baseline', project='IHU', customer='VCC', release='IP605', buildnr='12'
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}