$re = '/^#\s(?P<header>(\w+=\'\w+\')(,\s*(\w+=\'\w+\'))*)$/';
$str = '# type=\'baseline\', project=\'IHU\', customer=\'VCC\', release=\'IP605\', buildnr=\'12\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);