using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^#\s(?P<header>(\w+='\w+')(,\s*(\w+='\w+'))*)$";
string input = @"# type='baseline', project='IHU', customer='VCC', release='IP605', buildnr='12'
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}