re = /^#\s(?P<header>(\w+='\w+')(,\s*(\w+='\w+'))*)$/
str = '# type=\'baseline\', project=\'IHU\', customer=\'VCC\', release=\'IP605\', buildnr=\'12\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end