use strict;
my $str = ' 42 0050.348a.7a93 dynamic ~~~ F F Po3
* 82 3550.b5e7.0124 dynamic ~~~ F F Po1';
my $regex = qr/([0-9a-f]{4}[\.][0-9a-f]{4}[\.][0-9a-f]{4})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}