import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9a-f]{4}[\\.][0-9a-f]{4}[\\.][0-9a-f]{4})";
final String string = " 42 0050.348a.7a93 dynamic ~~~ F F Po3\n"
+ "* 82 3550.b5e7.0124 dynamic ~~~ F F Po1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}