package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9a-f]{4}[\.][0-9a-f]{4}[\.][0-9a-f]{4})`)
var str = ` 42 0050.348a.7a93 dynamic ~~~ F F Po3
* 82 3550.b5e7.0124 dynamic ~~~ F F Po1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}