const regex = /([0-9a-f]{4}[\.][0-9a-f]{4}[\.][0-9a-f]{4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9a-f]{4}[\\.][0-9a-f]{4}[\\.][0-9a-f]{4})', 'g')
const str = ` 42 0050.348a.7a93 dynamic ~~~ F F Po3
* 82 3550.b5e7.0124 dynamic ~~~ F F Po1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}