const regex = new RegExp('@\\w+|[a-z_A-Z]+(?=\\=)|(?<=\\=)\\w+(?# =后面的变量或者数字)|(?<=\\=)\\\\'.+\\\\'|(?<=\\=)\\".+\\"(?# =后面的字符串)|(?<=\\=)\\[\\S+\\](?#数组)', 'gm')
const str = `@asd aasdbadkjoiAJF=1123 b=abcABC_ANV c='abc_ABC ABC123' d="abc_ABC ABC123"
@bg a=[1,20,30,40] e=[x,y,z,w] `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}