import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@\\w+|[a-z_A-Z]+(?=\\=)|(?<=\\=)\\w+(?# =后面的变量或者数字)|(?<=\\=)\\'.+\\'|(?<=\\=)\\\".+\\\"(?# =后面的字符串)|(?<=\\=)\\[\\S+\\](?#数组)";
final String string = "@asd aasdbadkjoiAJF=1123 b=abcABC_ANV c='abc_ABC ABC123' d=\"abc_ABC ABC123\"\n"
+ "@bg a=[1,20,30,40] e=[x,y,z,w] ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}