using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@\w+|[a-z_A-Z]+(?=\=)|(?<=\=)\w+(?# =后面的变量或者数字)|(?<=\=)\'.+\'|(?<=\=)\"".+\""(?# =后面的字符串)|(?<=\=)\[\S+\](?#数组)";
string input = @"@asd aasdbadkjoiAJF=1123 b=abcABC_ANV c='abc_ABC ABC123' d=""abc_ABC ABC123""
@bg a=[1,20,30,40] e=[x,y,z,w] ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}