#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)@\w+|[a-z_A-Z]+(?=\=)|(?<=\=)\w+(?# =后面的变量或者数字)|(?<=\=)\'.+\'|(?<=\=)\".+\"(?# =后面的字符串)|(?<=\=)\[\S+\](?#数组)"
Local $sString = "@asd aasdbadkjoiAJF=1123 b=abcABC_ANV c='abc_ABC ABC123' d="abc_ABC ABC123"" & @CRLF & _
"@bg a=[1,20,30,40] e=[x,y,z,w] "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")