re = /^(.)\) (\S+).+Answer: \1/m
str = 'How may eggs are in a dozen?
a) 6
b) 9
c) 12
d) 16
Answer: c'
# Print the match result
str.match(re) do |match|
puts match.to_s
end