$re = '/^(.)\) (\S+).+Answer: \1/ms';
$str = 'How may eggs are in a dozen?
a) 6
b) 9
c) 12
d) 16
Answer: c';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);