using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.)\) (\S+).+Answer: \1";
string input = @"How may eggs are in a dozen?
a) 6
b) 9
c) 12
d) 16
Answer: c";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}