const regex = /^(.)\) (\S+).+Answer: \1/ms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.)\\) (\\S+).+Answer: \\1', 'ms')
const str = `How may eggs are in a dozen?
a) 6
b) 9
c) 12
d) 16
Answer: c`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}