$re = '/\"(\\\\\"|[^\s\"])*\"/m';
$str = ' String a = "";
String a1 = "\\"";
String a2 = "abc\\b\\"";
String a3 = "a" + 1 + "b";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);