package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\"(\\\"|[^\s\"])*\"`)
var str = ` String a = "";
String a1 = "\"";
String a2 = "abc\b\"";
String a3 = "a" + 1 + "b";`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}