using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""(\\\""|[^\s\""])*\""";
string input = @" String a = "";
String a1 = ""\"";
String a2 = ""abc\b\"";
String a3 = ""a"" + 1 + ""b"";";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}