import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"(\\\\\\\"|[^\\s\\\"])*\\\"";
final String string = " String a = \"\";\n"
+ " String a1 = \"\\\"\";\n"
+ " String a2 = \"abc\\b\\\"\";\n"
+ " String a3 = \"a\" + 1 + \"b\";";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}