$re = '/(\+|-)?(\d+x|\d+)(\^\d+)?/';
$str = '5x^10-3x^2+4';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;