package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\+|-)?(\d+x|\d+)(\^\d+)?`)
var str = `5x^10-3x^2+4`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}