#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\+|-)?(\d+x|\d+)(\^\d+)?"
Local $sString = "5x^10-3x^2+4"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)