using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\+|-)?(\d+x|\d+)(\^\d+)?";
string substitution = @"";
string input = @"5x^10-3x^2+4";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}