$re = '/(?=([\.]{1}[a-zA-Z_]+[\w\_\-]*)[\s\.\+\{\>#\:]{1})/m';
$str = '.aClass.foo.bar .qwerty {
border-bottom: 1px solid color.get(\'primary\');
padding: .5em;
background-color: color.get(\'background\');
.foo>.bar {
background-image: url("paper.gif");
}
.aCamelCaseClass {
}
#anIdThatShouldNotBeMatched {
}
.foo > .bar {
background-image: url("paper.gif");
}
.qwe+.rew>.qwe{ }
.qwe:hover
{
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);