#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=([\.]{1}[a-zA-Z_]+[\w\_\-]*)[\s\.\+\{\>#\:]{1})"
Local $sString = ".aClass.foo.bar .qwerty {" & @CRLF & _
" border-bottom: 1px solid color.get('primary');" & @CRLF & _
" padding: .5em;" & @CRLF & _
" background-color: color.get('background');" & @CRLF & _
" " & @CRLF & _
" .foo>.bar {" & @CRLF & _
" background-image: url("paper.gif");" & @CRLF & _
" } " & @CRLF & _
" " & @CRLF & _
" .aCamelCaseClass {" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" #anIdThatShouldNotBeMatched {" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" .foo > .bar {" & @CRLF & _
" background-image: url("paper.gif");" & @CRLF & _
" } " & @CRLF & _
" " & @CRLF & _
" .qwe+.rew>.qwe{ }" & @CRLF & _
"" & @CRLF & _
" .qwe:hover" & @CRLF & _
" {" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")