const regex = /(?=([\.]{1}[a-zA-Z_]+[\w\_\-]*)[\s\.\+\{\>#\:]{1})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=([\\.]{1}[a-zA-Z_]+[\\w\\_\\-]*)[\\s\\.\\+\\{\\>#\\:]{1})', 'gm')
const str = `.aClass.foo.bar .qwerty {
border-bottom: 1px solid color.get('primary');
padding: .5em;
background-color: color.get('background');
.foo>.bar {
background-image: url("paper.gif");
}
.aCamelCaseClass {
}
#anIdThatShouldNotBeMatched {
}
.foo > .bar {
background-image: url("paper.gif");
}
.qwe+.rew>.qwe{ }
.qwe:hover
{
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}