import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=([\\.]{1}[a-zA-Z_]+[\\w\\_\\-]*)[\\s\\.\\+\\{\\>#\\:]{1})";
final String string = ".aClass.foo.bar .qwerty {\n"
+ " border-bottom: 1px solid color.get('primary');\n"
+ " padding: .5em;\n"
+ " background-color: color.get('background');\n"
+ " \n"
+ " .foo>.bar {\n"
+ " background-image: url(\"paper.gif\");\n"
+ " } \n"
+ " \n"
+ " .aCamelCaseClass {\n\n"
+ " }\n\n"
+ " #anIdThatShouldNotBeMatched {\n"
+ " }\n\n"
+ " .foo > .bar {\n"
+ " background-image: url(\"paper.gif\");\n"
+ " } \n"
+ " \n"
+ " .qwe+.rew>.qwe{ }\n\n"
+ " .qwe:hover\n"
+ " {\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}