re = /(?<FirstShortcut>(?:(?:\w+\+){0,3})(?<FirstKey>\w+|.\d{0,2}))(?:,\s(?<SecondShortcut>(?:(?:\w+\+){0,3})(?<SecondKey>\w+|.\d{0,2})))?/mi
str = 'Shift+Ctrl+Alt+C, Ctrl+Shift+Alt+F1
Ctrl+PageDown
Ctrl+Home
A, B
Ctrl+F11, Ctrl+Home
Ctrl+,
F11
F1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end