package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?<FirstShortcut>(?:(?:\w+\+){0,3})(?<FirstKey>\w+|.\d{0,2}))(?:,\s(?<SecondShortcut>(?:(?:\w+\+){0,3})(?<SecondKey>\w+|.\d{0,2})))?`)
var str = `Shift+Ctrl+Alt+C, Ctrl+Shift+Alt+F1
Ctrl+PageDown
Ctrl+Home
A, B
Ctrl+F11, Ctrl+Home
Ctrl+,
F11
F1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}