const regex = /(?<FirstShortcut>(?:(?:\w+\+){0,3})(?<FirstKey>\w+|.\d{0,2}))(?:,\s(?<SecondShortcut>(?:(?:\w+\+){0,3})(?<SecondKey>\w+|.\d{0,2})))?/mgi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<FirstShortcut>(?:(?:\\w+\\+){0,3})(?<FirstKey>\\w+|.\\d{0,2}))(?:,\\s(?<SecondShortcut>(?:(?:\\w+\\+){0,3})(?<SecondKey>\\w+|.\\d{0,2})))?', 'mgi')
const str = `Shift+Ctrl+Alt+C, Ctrl+Shift+Alt+F1
Ctrl+PageDown
Ctrl+Home
A, B
Ctrl+F11, Ctrl+Home
Ctrl+,
F11
F1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}