using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<FirstShortcut>(?:(?:\w+\+){0,3})(?<FirstKey>\w+|.\d{0,2}))(?:,\s(?<SecondShortcut>(?:(?:\w+\+){0,3})(?<SecondKey>\w+|.\d{0,2})))?";
string input = @"Shift+Ctrl+Alt+C, Ctrl+Shift+Alt+F1
Ctrl+PageDown
Ctrl+Home
A, B
Ctrl+F11, Ctrl+Home
Ctrl+,
F11
F1";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}